Back to overview
Degraded

Ranking Logic Degraded

Apr 27, 2026 at 4:17pm UTC
Affected services
API

Resolved
Apr 27, 2026 at 8:38pm UTC

A push has been fixed & customers have been notified. Problem resolved.

Updated
Apr 27, 2026 at 7:07pm UTC

A fix is currently being pushed. Please hold.

Updated
Apr 27, 2026 at 6:51pm UTC

Update: After an oauth application is deleted ALL authorizations are automatically revoked. We are now working on getting a new oauth application deployed, this may take us another hour or two.

Updated
Apr 27, 2026 at 5:02pm UTC

We're attempting to work on a solution now. It appears that our oauth2 application no longer exists. This fix if deployed will with certainty require you to reconnect your workspace to Roblox.

Updated
Apr 27, 2026 at 4:45pm UTC

It appears our roblox oauth application no longer exists, we're attempting to get into contact with Roblox Support & make an alternative solution if need be.

Updated
Apr 27, 2026 at 4:42pm UTC

More investigation is being conducted.

Updated
Apr 27, 2026 at 4:20pm UTC

Issue seems to stem back to our roblox oauth2 application - this application is responsible for interacting with the roblox opencloud API.

Created
Apr 27, 2026 at 4:17pm UTC

Ranking Logic is currently degraded, error rates across the rankgun platform have increased. Investigation is ongoing. We will keep you updated.